Sunday, 29 January 2012 13:32

Migrating or Upgrading to Joomla 1.7/2.5

Written by 
Rate this item
(1 Vote)

It is that time again.  It seems that versions of Joomla are coming out sooner that you can upgrade to the next version. Not really, but sometime it sure feels that way.  Joomla just released this month (January 2012) version 2.5 of Joomla. You may be thinking, what a leap from 1.7 to 2.5, why such a drastic version number changing.  Like the previous version 1.5, the ".5" in the version number represents a LTR (Long Term Release).  You can read about Joomla 2.5 here.

"Along with new features such as advanced search and automatic notification of Joomla core and extension updates, the Joomla CMS for the first time includes multi-database support with the addition of Microsoft SQL Server. Previous versions of Joomla were compatible exclusively with MySQL databases."  There were also some changes to the Joomla core, so just because your extension runs under Joomla 1.6/1.7 does not mean it will run under Joomla 2.5.

With the new released, should you upgrade and/or migrate? That really depends on your current version of Joomla and also the other extensions you have installed and are running on your Joomla site. Lets take a look at the possibilities with the current version you are running. If you do not feel comfortable doing this yourself, we are available to help.  We can do the research on your extensions for you and then advise you to either have us proceed with the upgrade or hold off.  You can purchase some support time for your account here to get started.  If you want to "do-it-yourself", you can also learn how from attending one of our online webinars held weekly, more information is here.

If your site is currently Joomla 1.6/1.7.

This would be considered an upgrade. You need to consider the following:

  • Is the current template you are running compatible with Joomla 2.5?  You can usually find out by going to the template creator and asking if the current version is compatible, or if a new version is available for 2.5. If so then you can proceed to the next question, if not you need to decide either to wait or to switch templates.  If you do decide to switch templates and not wait, proceed to the next question.
  • Are the current extensions you are running compatible with Joomla 2.5? You need to check the 3rd party extensions you are running, are the components, modules, and plugins are compatible with 2.5.  This can be done by either going to JED (Joomla Extensions Directory) and checking there, or check directly with the developer's website to find an answer.  There were a few changes in some of the core code of Joomla 2.5, so you really need to check this out first before upgrading. If all of the extensions are Joomla 2.5 compatible, then you are safe to upgrade, if not you need to decide either to wait for the extension to be 2.5 compatible, change extensions, or just stop using that extension.

When you are ready to proceed with the upgrade, then you can do it via the Joomla back end-->Extensions Manager-->Upgrade. Remember to backup your site and database first, just as a precaution.

If your site is currently Joomla 1.5

This would be considered a migration. You need to consider the following:

  • You need to decide either to migrate to Joomla 1.7 or 2.5.
  • Is the current template you are running compatible with Joomla 1.7 or 2.5?  You can usually find out by going to the template creator and asking if the current version is compatible, or if a new version is available for 1.7 or 2.5. If so then you can proceed to the next question, if not you need to decide on another template. Let's face it, if it not available for at least 1.7 as of yet, it probably will never be.
  • Are the current extensions you are running compatible with Joomla 1.7 and/or2.5? You need to check the 3rd party extensions you are running, are the components, modules, and plugins are compatible with 1.7 and/or 2.5.  This can be done by either going to JED (Joomla Extensions Directory) and checking there, or check directly with the developer's website to find an answer.  If the extensions is still not available for at least 1.7, then it probably will never be, so you need to drop that extension or replace it with another one.

Depending on the information gathered above you need to decide on the following:

  • Migrate directly from Joomla 1.5 to 2.5, or
  • Migrate from 1.5 to 1.7, then later update to Joomla 2.5
Read 1570 times Last modified on Sunday, 29 January 2012 22:04
Login to post comments